[HELP] Edit Collider Missing From Paddle Prefab But Not Instance In Level

Observed Behavior:
When replacing Box Collider 2D on the Paddle with Polygon Collider 2D, the “Edit Collider” button does not show in the Polygon Collider 2D section of the Inspector. However, if I click the instance of the prefab paddle in the scene, the the “Edit Collider” button does show in the Polygon Collider 2D section of the Inspector. I am not sure why it is not showing on the prefab.

I should state that I am using Unity 2017.1.0f3. I understand that it is recommended that I use the version of unity specified by the videos, but I want to learn the newer version. Up until now, the answers in the forums have kept up with Unity 2017 with the discrepancies. It isn’t a huge deal, I was just hoping someone might know off the top of their heads.

Expected Behaviour:
When I look at the prefab in the Prefab folder, I expect to see the “Edit Collider” in the “Polygon Collider 2D” section of the inspector window.

Steps to Reproduce:

  1. In Lession 94, Remove the “Box Collider 2D” from the Paddle prefab using the Inspector pane.
  2. Then add “Polygon Collider 2D” to the paddle prefab.
  3. Attach the Ball material, and uncheck the “Is Trigger” option.

Things I Have Tried:

  • Resetting the Polygon Collider 2D.
  • Removing and re-adding Polygon Collider 2D

Image of “Polygon Collider 2D” in the inspector pane with the paddle prefab selected in the Assets folder:

Image of “Polygon Collider 2D” in the inspector pane with the prefab selected in the Assets folder:

I have the same issue.

I have tried working on the instance and replacing the old prefab with this instance but my other scenes got really messy. A Google search didn’t really return much results so few people experience the same, maybe some minor thing we are missing. Would to love to get some feedback on this question…

I’am also in newer Unity version, btw.


One thing you can do is edit the Polygon Collider on the Paddle instance which is in your Hierarchy or Scene and then click ‘Apply’ which is just above it’s Transform component in the inspector (when you have the paddle selected in the scene).
This way, the changes you made to your Paddle instance will get applied to the Paddle prefab as well.
Hope this helps.

Cheers & Good Luck,

1 Like

I just noticed my problem is different from OP because he the ‘edit collider’-button doesn’t show, where in my case the ‘edit collider’-option is greyed out thus unclickable

Thank you @Yash_Agrawal for your reply because it appears to be working. It still feels like a workaround though. I am missing something, but can’t find what it is.

1 Like

I am glad I was able to help.
One of the reasons the ‘Edit Collider’ option could be grayed out is because, to implement the editing, you will need to have an instance of the prefab in your playspace.
What I mean is, when you edit the collider shape, you do it on an instance in your playspace, right?
So maybe that’s why it’s grayed out in the prefab inspector.
Hope this helps.

Cheers & Good Luck :slight_smile:

Privacy & Terms