Help! Console command ingame is unable to find custome commands :(

uem_s01_console_commands_with_exec

#1

Hey guys,

So i created the Game instance and populated it with the right code. I too set the right gameinstance in the project settings. Then when i summon the cmd ingame, and i type the function names it cannot find them both :frowning:
Help!!!

Im using Visual Studio 2017, Visual Assist, Unreal engine projects 4.17 and 4.19. (both wont work)

CMD

CMD2


#3

I remember having an issue with this at first as well, although I canā€™t seem to reproduce it now. Have you tried rebuilding the PuzzlePlatforms C++ project? Also, are you seeing the issue when you play in a new editor window?


#4

Iā€™m also having the same problem. The commands are not recognized. Init is not being called
also. The constructor is.
Using UE 4.19 and code from the GitHub.


#5

I tried this code in different class for UE4.19ā€¦but this is not working for me.
I downloaded the last version project from githubā€¦but this is not working for me.
I didnĀ“t found any chance In UE4 documentation. Any help?


#6

ResolvedĀ”Ā”Ā”
New Cmd is working in a different contextā€¦open a classic cmd consoleā€¦
Go to Project Settings-> Input-> Console-> Console Keysā€¦pick a new key to open a classic command consoleā€¦
GL

PD. In ā€œAddOnScreenDebugMessageā€ change Key==0 to Key==INDEX_NONE