Game with no Sound after building :O

32_pb_cu2
project-boost
3d
#1

Try out my brand new game!!

CONTROLS:
Space = thrust
A = rotate left
D = rotate right

Please, give feedback about the gameplay, physics…

0 Likes

#2

Hi Gabriel,

There is a NullReferenceException in the Chrome browser console. Perhaps it’s related to your issue. Please follow Rob’s instruction.

0 Likes

#3

Thank you, Nina. But I am still having this sound problem, even after following Rob’s Instructions.

0 Likes

#4

Do you have any error messages in your Unity Console while playing your game inside Unity? Have you tried to build it to another platform?

Depending on your version of Unity, it could be a bug. Updating might help.

0 Likes

#5

Yes, I am getting errors in Unity Console, I have seen that just now.
It says:
There is no ‘AudioSource’ attached to the “Body” game object, but a script is trying to access it.
There is no ‘RigidBody’ attached to the “Body” game object, but a script is trying to access it.

0 Likes

#6

Fantastic. Now check your game objects whether the components are missing.

0 Likes

#7

I don’t know why, but unity was creating scripts inside in one of my ship parts. I deleted them and made my script again and attached to the ship prefab. The errors stopped showing up. Thank you for your help, I will try to build the game again.

0 Likes

#8

But still, no sound

0 Likes

#9

Could you upload the new developer build?

0 Likes

#10

Yes, did it and just updated the link. I thought it was a Chrome problem but there is no sound on Firefox either

0 Likes

#11

Could you share the link, please?

0 Likes

#12
0 Likes

#13

Is this the new build? According to the URL and the output in the Chrome console, it seems to be the same as in your initial post.

Furthermore, which version of Unity do you use? And did you try to build your game with Unity 2018.3?

0 Likes

#14

I will try updating my unity , make the build again and upload the new version.

0 Likes

#15

There we go, Nina!! Thank you very much for your help! Sound is working OK now.

0 Likes

#16

I’m glad I was able to help. :slight_smile:


See also:

0 Likes

automatically bumped #17
0 Likes

automatically bumped #18
0 Likes

closed #19

This topic was automatically closed 24 hours after the last reply. New replies are no longer allowed.

0 Likes