Exporting to the simulated device fails

Not sure what I’ve been doing wrong here, but here is what I get when I try to launch the game on the simulated device:

I tried two configurations:


And then I get the error message from the first screenshot.

Not sure if I missed a step somewhere.

I apologise for missing this initially it slipped through my searches.
I also had a horrible time trying to get this working for any android phones, When i did get it to launch after multiple different versions often the phone screen wouldnt load and i never ended up getting the game to run.

I believe the error you are getting is due to a mismatch in the versions with the phone (I think i had to remove 33 and use 32 or something).

My best suggestion is to try using a mobile phone as this is really just an option in case you do not have a mobile phone that you can test with.

I have followed all the instructions to setup Android for export. I purchase a refurbished Motorola Moto G7 running Android 9. I am able to successfully export this project to the phone. The app runs perfectly. Unfortunately, I have been unable to export the app to a simulator. The app icon is on the simulator, but when I click on it the app tries to start and then crashes. I am developing on an Apple M2 Max laptop. In this lesson the instructor is using Windows. Is it possible to run on a simulator on a Mac?

Hi J_Lincon_Barr,

I had lots of issues with the app working on windows as mentioned above so i think this is pretty much a hail mary if it works for you.
Even when i did actually get it to run the app correctly, i could try again a second time without any changes and it would either refuse to run the phone simulation or run the game as intended.

I dont think this is a mac thing but rather that the app just is not very well done.

I’ve not worked through the course as yet, have to wait till I’m on wifi at home, but just done a bit of reading up to try and help a little.

I’m wondering if this might be someting to do with the target architecture vs what’s being exported from godot in the apk.

Does the emulator allow you to select an architecture to use?

Looking at the pixel Pro 7 on a quick search, looks like it’s running armv8. Arm7 and 8 are generally selected as default tho.

I’ve also read on the manual that it might I there’s already a package with same name installed on device that needs to be removed first.

Thanks and no worries, it was not something urgent anyway.
I use a phone for most my tests, I just wanted to try out the different options.
I’ll definitely try again with 32 instead and see what it does.

This topic was automatically closed 20 days after the last reply. New replies are no longer allowed.

Privacy & Terms