Easy Fix for Emulator Export Errors

Hey everybody,

I’m too late to respond to @AssaSquid’s post, but when I initially tried to do the one-click export to the emulator I got the same error:

… [INSTALL_FAILED_NO_MATCHING_ABIS: Failed to install native libraries] …

(Sorry I wasn’t on the ball and I forgot to take a screenshot of the error before I fixed it.)

However, after looking through the replies to that post, I did a quick search and found this page regarding 64-bit architecture on Android and the requirements for the Google Play Store and was able to come up with an easy fix that seems to be holding up fine so far. The issue I think is with the godot export, not with the emulator.

This is the relevant bit from that page you want to pay attention to:

I then looked at the details of the phone model I chose for the emulator on Android Studio in my Device Manager by clicking the three dots to the right of the play arrow and selecting “View Details”. I was using a Pixel 7 and under the Summary you can see that the ABI list is “x86_64”.

So then what I did was go into the export settings in Godot and go to the “Architectures” section, select “x86 64,” and re-exported. After I did that, the game exported, installed, and ran on the emulator no problem.

Just a thought, but Kaan mentioned that he used a Pixel 6 model for the emulator that did not have Play Store support, so perhaps that is why he did not need to have any additional export options?


I had the same error a couple weeks back and had to change architecture version for Mt Mi 9.

Post should help alot of students who search here.

Cheers for sharing your experiences and workaround.


Privacy & Terms