Error CS0246: The type or namespace name 'TMPro' could not be found

Unity Dialogue & Quests: Intermediate C# Game Coding : Atomic design

I have not asked any questions to the forum before but I cannot solve this problem. When I use TextMeshProUGUI in script it uses namespace TMPro in Visual Studio Community 2019.

When I go back to Unity 2020.1.8, it doesn’t recognize the namespace with the above error message.**

I use TextMeshPro 3.01. I have looked for a solution in 3 days. I tried to move TextMeshPro into my project but then TextMeshPro was damaged with no scripts in folder so I had to reinstall Unity 2020.1.8. I don’t know now how to get this working.

I solved the problem now by adding assembly script in my script folder referencing Unity.TextMeshPro namespace.

I’m glad you were able to get that working… My advice was going to be to go to the Package Manager window, uninstall the TextMeshPro package (if it was even there), and then reinstall it through the Package Manager. It’s supposed to be one of the base packages, included in every new project until you take it out. I’m not sure how that didn’t work, unless they’ve taken it out of the default project in 2018.1.8 (or you migrated the project from a previous version, which often has one problem or another).

Thanks for your answer Brian.
A little background:
I started with RPG Core Combat, continued with RPG Inventory Systems and now Unity Dialogue and Quests. I believe my project was first made with Unity 2018.4, then converted to 2019.4, and now 2020.1.8 soo maybe that is the reason why also when changing different versions of TextMeshPro made TextMeshPro not working.
I tried to remove and reinstall TextMeshPro before with no success soo I was lucky that adding assembly script now worked perfectly.

1 Like

This topic was automatically closed after 34 hours. New replies are no longer allowed.