Error creating GameNetDriver

I keep getting an error when I click the host button:
[2023.12.19-20.40.16:159][686]LogNet: CreateNamedNetDriver failed to create driver from definition GameNetDriver
[2023.12.19-20.40.16:159][686]LogNet: CreateNamedNetDriver failed to create driver GameNetDriver from definition GameNetDriver
[2023.12.19-20.40.16:160][686]LogNet: Error: UEngine::BroadcastNetworkFailure: FailureType = NetDriverCreateFailure, ErrorString = , Driver = NONE
[2023.12.19-20.40.16:160][686]LogNet: Warning: Network Failure: NULL[NetDriverCreateFailure]:
[2023.12.19-20.40.16:160][686]LogNet: NetworkFailure: NetDriverCreateFailure, Error: ‘’
[2023.12.19-20.40.16:161][686]LogNet: Error: LoadMap: failed to Listen(/Game/ThirdPerson/Maps/ThirdPersonMap?Name=Player?listen)

I’ve checked the code against the course, checked the defaultengine.ini, made sure Steam is both active and closed, same error every time. Any help would be appreciated.

Just a few things to Check Stephen.

First, Ensure you’ve included the maps in the package section.
Second, try this with a packaged build.

For steam, it seems some people have issues trying to use steam and the only solution is to use a packaged built. you can run this with -WINDOWED -log and you’ll get a log window in the background. There’s a way to capture the log to a file as well but I can’t remember how.

Give these a try and let me know how you get on.

No, that hasn’t worked. I even deleted the project and recreated it in case I missed a step first time around. Same problem.

Strangely though, I have also done the Sam Pattuzzi Unreal 4 C++ Multiplayer Master course, but in version 5.2, same as this course. I don’t have this problem and the connections work fine.

That’s interesting. It will have something simple missing somewhere.

If you upload your project (zip the folder after deleting intermediate and binaries) to and I’ll try get to it as soon as I can. May be a few days…

Privacy & Terms