Error C1189 after including DXSDK first in Directories

I am using Windows 10, VS2019, and have installed dxsdk_jun10.exe.
I still get #error: “This version of XAudio2 is available only in Windows 8 or later. Use the XAudio2 headers and libraries from the DirectX SDK with applications that target Windows 7 and earlier versions.”, even when including DXSDK first in the VC++ directories like in the video

1 Like

There is a better way but at the moment I can’t get at them. Will be able to share tomorrow.

For now, using the sdk, you have to add the paths to the includes and libraries in the project properties. Make sure it is at the start.

The error is because it is trying to find it within the windows SDK because you’ve not given it an alternative place to look.

Here’s the alternative steps to building Steamworks

I just tried that but for me the issue is still occurring.
I do not understand what is meant in lecture “48. Errors Building SpaceWar” when it says:

“In the Project Navigator, right-click on the “Headers” virtual folder and choose “Add files to ‘steamworksexample’…”, then look for a file named RemotePlay.h in the source code folder of the example project. Select it and confirm addition in the “Headers” virtual folder.”

This is what I haven’t been able to do as of yet. I don’t see a Headers virtual folder. Is the Project Navigator the same as the Solution Explorer?

So I got it fixed by using the NuGet link that they refer to in the error message and I have got a completely new error message:

I don’t know what to do with that :confused:

1 Like

I’ve never seen this either to be honest. Which version of steamworks are you trying to build?

Don’t let this hold you up in the course. The main purpose of these videos is to give you an idea of the functionality steam offers.

I have the same error, did you solve it :(? In my case just comment line 156 and the game runs but it’s strange that works

I’ve heard that works. Also, someone also said once you’ve built, uncomment and it behaves.