Discussion for importing attack animations

In this particular lecture we imported animations for attack. Any questions or thoughts on this?

Rick,

In the new rpg remake…

The trigger is supposed to reset automagically on action, it tends to “stick” only if it was transitioning between something at the time… As a result my tigger doesnt stick, it fires a punch and pretty much from the instant it starts that animation trigger is auto turned off waiting to be triggered again.

I thought I was going nuts, cos I thought my triggers had always auto reset but I found this https://answers.unity.com/questions/981044/animator-trigger-not-reseting-bug.html which seems to confirm the behavior in the video is not what it should be. You shouldnt need to click to turn it off.

In the next lesson Sam mentions this, I thought I was losing it

Thanks for sharing this. From what you’re saying, it sounds like its a bug that occurs under our “not yet fully implemented” test scenario, right? Let me know if you see it causing more mischief down the line.

Seems to be, it just could confuse people if theirs acts “like it should” and doesnt stay on as it does in the tutorial.

Deleting post:

after a long long time of trying to figure out my issue, i forgot to attach the ActionSchedular to my character ;/. its working now

Dear Rick,
I have created a new character and associated animations to it under blender and have exported to unity.
under unity all the animations worked but the attack animation didn’t inflict damage to the enemy. what could be wrong to the attack animation that i created?

Sorry Rick but I have found my erreur. I had to create an Event Hit for the Attack animation.
thank you

1 Like

Well done in sorting that, Haile, it’s a common issue. The Explosive animations provided with the coursework already have the Hit animations built in, so it’s easy to forget them in ones you make in blender or import from 3rd party sites like Mixamo

Glad you figured it out!

I ran into an issue importing the Mecanim assets that now state they require the new UI input system. This requires some significant changes to wire up the Input Manager to the actions. A cleaner system, but I think you might need to update the tutorials based on these changes in Unity and the assets.

Which assets are you referring to? It’s likely, if it’s a 3rd party asset, that it’s including a sample controller which won’t be required for this course series.

Section 33, adding attack animation, links to RPG Mecanim Animation Pack.

As the description now notes (and several recent reviews ask) it says:

Note: This asset requires the InputSystem package to be installed:

Ah, I see it now, you’re referring to the paid Explosive asset pack.
The scripts in this asset pack, even before they upgraded them to the new Input system, are not compatable with the RPG course. You can delete them, or simply not add them to the project on import.

Ok - back to working.
I rolled back the changes to Player Settings to use the old input, removed the various other assets. Since this was a recent change with the asset (November 23, 2020) it may be encountered by other students. Maybe a note in a future version about importing only animations

More generally, the new input system looks compelling. I would appreciate any insight from you on using it in other projects.

I haven’t done a great deal with it. Our new course on networking in Unity dips it’s toes into the new Input System waters. Up until recently, it didn’t meet the threshold for inclusion as a course topic (we don’t like to teach something that is still in the experimental stage, as Unity has a nasty habit of making project breaking changes). The new input system is now live and no longer in early access. I think you’ll start seeing it appear more in future courses.

1 Like

Thanks.
I’m now running into an issue which I expect is my fault, but want to check given my project got into a bad state with input system.

When testing the animation and enable “attack” I immediately see an error

‘Player’ AnimationEvent ‘Hit’ on animation ‘Unarmed-Attack-L3’ has no receiver! Are you missing a component?

And then when I disable attack the animation won’t update.

Does this sound familiar as something that I’ve missed a configuration or component?

Proceed to the next lecture and all should be made clear. :slight_smile:

There’s an “Error Pause” option in the console - animation will play if you disable it.

1 Like

Thank you very much! I had the same problem.

Privacy & Terms