Crashes when I click Host using PIE [Solved]

TLDR: You cant host games if you are using PIE with a dedicated server.

Works fine if I run the game from powershell. I have deleted the binaries and the intermediate folder from my project and rebuilt them. The console command ‘Host’ also crashes. It says its crashing on if (!ensure(PlayerController != nullptr)) return; but that doesnt seem right unless there is something wrong in ensure.

Also I just noticed that when I attempt to launch UE4 from VS debugger (using DebugGame Editor) it says that it cant find …/UE_4.24/Engine/Intermediate/Build/Unused/UE4.exe because the exe is not there.

I’m debugging as I’m writing this to try and provide as much information as possible and after swapping that ensure statement to just if(PlayerController == nullptr) return' I now received the error

Assertion failed: Ret != EBrowseReturnVal::Pending [File:D:/Build/++UE4/Sync/Engine/Source/Runtime/Engine/Private/UnrealEngine.cpp] [Line: 12142]
If you go to that line they are trying to log a warning because // server travel should never create a pending net game but it shouldnt be crashing.

Thanks for sharing this.

This topic was automatically closed 24 hours after the last reply. New replies are no longer allowed.