Compile Failed

The project has been working fine up until now, I’ve just tried to create my C++ Class OpenDoor and was met with a compile error.

I’ve opened VSCode which shows that the class has been created and the .h and .cpp files are in there ready for me to use, but it’s not being added to the door in Unreal.



When I try to compile, this the error I get in message log:

And this comes up in the output log:

I didn’t have either of these come up in BullCow so I’m not sure what to do!

My unreal version is 4.22.3
My XCode version is 11.7
I also have noticed i have XCodeClangFormat (which I’ve not seen before?) and the version is 1.2.1

I’ve made sure that my path doesn’t contain any spaces, it’s relatively short i think!

I’ve gone into Xcode and changed the preferences/location to Xcode.

I’m really stuck now! Any help is appreciated thank you as I’ve really been enjoying the course and want to crack on!


I changed the path in the terminal for Xcode by using xcode-select -p and sudo xcode-select --reset so I’ve got rid of 1 error but still super stuck on the other!


Looks like you’re running into this: UE4 Editor error when creating new project on Mac

I don’t know why it changed for you that your project broke, but something must have along the way.

1 Like

Thank you! :slight_smile: I reset my path and it worked!

This topic was automatically closed 24 hours after the last reply. New replies are no longer allowed.

Privacy & Terms