Compile errors with .json files?

Is this happening to anyone else?

When I try to compile, it returns the error:
ERROR: Unhandled exception: Dependency file "PathtoProject\ObstacleAssault\Intermediate\Build\Win64\UnrealEditor\Development\ObstacleAssault\MovingPlatform.cpp.lc.json" version ("1.2") is not supported version

Navigating to the directories, and changing all the versions of the .json files from 1.2 to 1.0 temporarily fixes things (I found other people who had the same error and fixed it that way), but every time I compile, it generates new .json files that revert back to 1.2.

How do you fix this?

Can you compile with Unreal closed?

Yes, this happens when I recompile using live coding

Does this work for you?

I have this problem when building from VS Code, the solution posted by DanM doesn’t change anything. I even tried restarting the pc.

Edit:

After the changes posted di DanM I kept having problems with an error like
LINK : fatal error LNK1181: cannot open input file ‘delayimp.lib’

In the end I found a fix but I don’t know how to implement it in VSCode so just switched to Visual Studio:

Opening the solution, going to Project → Properties → under Configuration Properties → VC++ Directories → and adding $(LibraryPath) as a Library Directories

Don’t know why but after a day of uninstalling and fixing things only this solution using VS2022 works.

Has there been any updates to this problem? I am unable to move forward. I have tried both VSCode and Visual Studio 2022. Solutions above are not currently working
image

I went into the file path where the JSON files were located. I think after the fix DanM suggested you have to go into the file path of the error and delete the old files. It is working now…

I’ve got to section 3, video 44. This is as far as my compiling gets

This is what I have done:

Did you do a full rebuild after applying that workaround? You can ensure that by deleting the Binaries and Intermediate folders.