Command Line Issues

I could not get this working with the instructions in this lecture – I had to go to the next lecture with ClientTravel to get it to work. Maybe it’s something wrong with the order of my parameters to join the client after the host is enabled… but either way could not figure it out. This is what I did:

If I launched the game from the powershell -game enabled and lobby map specified in the parameters ie:

PS C:\Windows\system32> & “C:\Program Files\Epic Games\UE_4.18\Engine\Binaries\Win64\UE4Editor.exe” “C:\Users\ben_u\source\repos\UnrealCourse\PuzzlePlatform\PuzzlePlatform.uproject” -game -log -windowed -resx=1280 -resy=720

and then ran ~ “Host” I could move from the lobby into the ThirdPersonExampleMap map. However, if I then tried to join a new client from the command line with the IP specified and the ThirdPersonExampleMap map specified it did not join the multiplayer server session – the result was two game windows both in the ThirdPersonExampleMap map individually but no multiplayer (ie only 1 person in each room). This was the second client command:

PS C:\Windows\system32> & “C:\Program Files\Epic Games\UE_4.18\Engine\Binaries\Win64\UE4Editor.exe” “C:\Users\ben_u\source\repos\UnrealCourse\PuzzlePlatform\PuzzlePlatform.uproject” /Game/ThirdPersonCPP/Maps/ThirdPersonExampleMap -game -log -windowed -resx=1280 -resy=720

The only way I was able to get the intended result of two people in the same room was to complete the following lecture on ClientTravel – then it all worked fine.

Did you try adding the “?listen” suffix to the map? I updated the video to include this fix too.

1 Like

Privacy & Terms