Collision Settings for UE v4.12 Bouncy Tank

Hi all. First off, absolutely love the tutorials Ben. You are a god send. You can’t find these kind of UE4 C++ tutorials online. Thank you so much.

As far as the bouncy tanks. I think I have it pretty much nailed down. I have pictures attached for the collision settings, which are the only things that need to be changed. First off, I went into all the static meshes and removed the auto mesh colllisions under the LOD settings. Then, I added 18 DOP collisions in the collision drop down menu.

Then, it was on to the tank pawn blueprint. Make sure generate overlap events is enabled for each static mesh components. For the base tank body, I left simulate physics enabled, but I changed the collision preset to custom. I left all the settings the same except I changed the object type to Pawn. The object type for the other four meshes were all set to World Dynamic.

For the turret, I change the preset to overlap all dynamic. Then, I went back to the preset and choose custom. Everything remained overlapping except I made world statics and world dynamics to block.

For the Barrel itself, I changed the preset to overlap all dynamic and left all the other settings as is.

For the tracks, I changed the preset to block all dynamic at first, and then set it to custom. The only things I changed in custom was setting the tracks to overlap physics body and pawns.

I’m still having a slight bit of trouble with SuggestProjectileVelocity. It works 90% of the time, but when aim at something very far away, and especially something on a higher elevation, it doesn’t register. Maybe this is solved in a later video. Good luck. - zip of all 4 images.

Well, sadly it doesn’t help at all.

worked for turret elevation, but bounciness returned once I coded in turret rotation.

taking info from another topic, Uncheck autoweld on the tank turret seems to fix everything. Unchecking it on the Barrel won’t hurt either.

Privacy & Terms