Client Travel Fail Fix

Thought I would share this with you guys but I was having that Client Travel Fail problem and this actually fixed it for me, maybe TEXT is doing something with it when Appending it that way? Either way manually entering the URL with ?listen on the end fixed it for me.

It seems that the server was simply not launching as a listen server.


So I refactored this and printed it out to see what it was doing and for some reason ?listen was excluded…maybe this is some formatting thing? Anyway I was able to achieve the same thing by adding it to a string and then using Append to add ?listen to the end…

I think what may be happening is that we are storing the String ‘ServerMapURL’ and I am assuming the String has some character that is used to mark the end of the String. Maybe I’m totally off the mark on this but could it be possible that the end of the actually String may be somehow conflicting with the ? symbol or that a newline character from it is included causing it to either bump it to a new line or ignore the ?listen altogether?

This is indeed interesting. I’ve been fighting with this stuff and spent way too many hours trying to find a solution. I have a few weird behaving projects so I’ll give this a try and see if it helps.

RE the question mark. They probably used that because it is also used in URLs to denote the start of parameter lists.

1 Like

Yeah I would have expected that to not be a problem, it really does seem like a bug too me. Maybe it’s just somehow related to how it handles it in memory but idk. I’m still new to all of this.

My thoughts were that maybe there was a \0 character at the end of the string in memory and when using the %s?listen it was doing \0?listen and maybe that had some significance? Like I said though I’m still pretty new and unfamiliar with all that formatting stuff.

1 Like

I actually just took a look at my code and this may be something I’m overlooking in student code. I already had the append. Pretty sure I picked this up from the course so wondering if it is a missing step by those encountering the issues. Still not had a chance to look yet.

1 Like

I suppose, I mean it’s not difficult to overlook something when going through a course. When I first started I would have to double back regularly to see what I did wrong.

1 Like

I know, I did it myself when running through the UE Stealth Combat course - missed a checkbox which meant some things didn’t work as expected.

These things happen

1 Like

Privacy & Terms