Clicking through posted links - same page or new tab


#1

Afternoon all :slight_smile:

Just a thought and a suggestion, did have a look about but couldn’t see a related topic.

Looking at user generated links in posts, is there a preference that can be set to have the clicked though links open up in a separate window/tab rather than lose focus on the forum page as they currently open in same window.


#2

I think Discourse may support this, there are some mentions of it on their own support pages back in April. It looks like there was an issue however with links that were clicked on rather than keyboard use.

Update:

There is a post in the Unity forum regarding a bowling issue, the link to the OPs video opens in a new tab for me.

I wonder whether perhaps external links are opening in a new tab, but internal links are not?

External: http://www.google.co.uk

Internal: Pins not resetting after Renew and Pins being hit during Tidy. Video inside

Yep… that appears to be the case.

Of course, you would only want links within posts to open in a new tab, not the links to other courses/sub-forums, that would get a bit crazy…


#3

Sound, that explains it, was just something that was rattling round my head :slight_smile:
I wasn’t sure if i missed something


#4

Have you tried to click a link with your middle mouse button or ctrl-key + left click? That should open links in new tabs (on all sites).


#5

Both those links you posted open in this window, not a new tab, for me.


#6

I didn’t know about the middle scroll wheel/button press @GamedevCala - thanks! :slight_smile:


#7

That’s interesting @chris.claus42, I just checked them again and mine, by default do what I mentioned above. I am using Chrome. Wonder if you have any settings in your browser that are forcing the page to load in the same window, a don’t open new tabs kind of option?


#8

Nope, because when I try my works website, links to external pages open in new tabs, so I don’t think its a problem with my browser.
I’m using Chrome, most of the settings should be default.
When I get home, I’ll try it on my computers there.

When I view the source of this page, the only difference in your two links is that the one to google has rel=“nofollow” it doesnt have a target="_blank"


#9

Nevermind. I figured it out.

If you click on your icon in the green bar, and click the gear icon it takes you to your site preferences.
Scroll down almost to the bottom, one of the check boxes will say " Open all external links in a new tab"
Mine was unchecked. Probably by default as I dont recall ever changing it before.


#10

BOOM - nice spot @chris.claus42, I shall try to remember that should anyone else ask in the future, good find thanks :slight_smile:


#11

Nice one Chris, never seen that, sorted it right out :wink:


#12