Can't live build

I don’t have an issue on my end but it seems the recent update to Visual Studio broke things for some people.

Someone in the Udemy Q&A posted a solution.

Open the Visual Studio Installer from your Windows Start Menu. Then Modify then go to Individual Components and select to installer an older toolchain

Then update the BuildConfiguration.xml to use that. Open File Explorer and use the address bar (or alternatively Win + R) and go to

%APPDATA%/Unreal Engine/UnrealBuildTool/

Then open the BuildConfiguration.xml file in a text editor like notepad or VS Code and edit its contents so that the following is within <Configuration> </Configuration>

<WindowsPlatform>
<Compiler>VisualStudio2022</Compiler>
<CompilerVersion>14.30.30705</CompilerVersion>
</WindowsPlatform>

e.g.

<?xml version="1.0" encoding="utf-8"?>
<Configuration xmlns="https://www.unrealengine.com/BuildConfiguration">
<WindowsPlatform>
<Compiler>VisualStudio2022</Compiler>
<CompilerVersion>14.30.30705</CompilerVersion>
</WindowsPlatform>
</Configuration>

It still shows the same result.

Are you able to edit those files and change the version to 1.1?

I meant the JSON file mentioned in your original screenshot.

yes, i can but it still shows the same error as the original screenshot.

Could you show screenshots of both?

I have solved it.
I changed all the files with version 1.2 to version 1.0 .

Where I am after trying the buildConfig

solution:

I was suggesting you modify the json files to version 1.1 not the xml

Did you delete the Binaries and Intermediate folders after applying the fix?

Yes, I know get this error:
‘The following modules are missing or built with a different engine version:
OstacleAssult
Would you like to rebuild them now?’

[Yes]

‘Could not be compiled. Try rebuilding from source manually.’

Log: ObstacleAssultU-backup-2022.05.20-10.18.04.log · GitHub

I believe that’s from the Windows SDK. From searching in individual components, which one do you have installed?

I have 10.0.19041.0 installed and I don’t believe I changed mine at all when I was testing the build tools.