Can't find the utility scripts..what should i have to do?

I updated Unity and reinstalled it but nothing changed, i’m stuckedunity%20problema


Hi Matteo,

Are you referring to the .unitypackage that is made available via the Resources on Udemy?

If so, you need to download the file, then extract it (as it will be a compressed .zip file I believe). You will then have a .unitypackage file which, when you click on “Import Package” and “Custom Package” you will be able to browse to and select. Upon doing so you will see a dialog window which will allow you to select the specific items from the package you wish to import.

Hi Rob,
Sorry, I was referring to unity’s waypoint utility scripts. Ben said that if you can’t find them as i screenshotted you have to install them from the unity download assistant but even it didn’t ask me to install that specific package. I tried to reinstall Unity 3 times,still not found’em.


I see. I believe what you may be referring to are the Standard Assets. Depending how/where you install Unity from may change how you install these. If for example you download and install the Unity Installer you’ll be provided with an option to select for their installation. If however you just download the Unity editor, you won’t.

As you are already installed now, the easiest solution would be to open the Asset Store window/tab within Unity, the search for “Standard Assets”, you’ll see them in the listing, possibly amongst others, so check that it is the assets by Unity Technologies.


There will be an option to “Download” and then one to “Import” if you do this via the Unity editor.

Hope this helps :slight_smile:

See also;


Hi Rob,
Thank you very much Rob! You saved me, thank you for being that kind.
Now i can finally go back to work :smiley:

1 Like

You are more than welcome, I am glad you can move forward with the course :slight_smile:

This topic was automatically closed 24 hours after the last reply. New replies are no longer allowed.

Privacy & Terms