Can't Edit My Animations

Hi, I saved and reopened my Argon Assault project to continue editing my player ship animations, however they no longer appear in the animation editor tab when I click on the Player Rig object (or the child Player Ship object).

Everything works fine in the player, but the animations are now in a Master Timeline object and I can’t edit them. I’ve tried removing the animator component that got added to my Player Rig, right-clicking “Edit in Animation Window”, and restarting Unity but the record button is still greyed out. I could just redo the animations but I’d like to figure out what’s gone wrong. Thanks in advance

Hi,

Welcome to our community! :slight_smile:

Actually, this should have worked. Your screenshot shows the animation. Or is it the wrong animation?

Have you already tried to click on one of the diamond shaped keyframe icons?


See also:

Ok I think it’s working now. I still can’t record in the animation window for some reason but I can edit in the Timeline editor. Thanks

This topic was automatically closed 24 hours after the last reply. New replies are no longer allowed.