Can't build steamworks on Windows 10 and visual studio community 2019

I’ve tried all suggested solutions, and nothing works. Also DirectX SDK June 2010 is nowhere to be found anymore as Microsoft has allegedly removed the installer, and the DirectX headers and libraries included with the WIndows 10 SDK won’t work either (neither for 10.0.17763.0 nor 10.0.18362.0).

Microsoft is no longer distributing the installer but if you google DXSDK_Jun10 there’s a few sites that are hosting it.

The article explaining why they stopped distributing it:

Thank you for your reply @geminfry. Yeah, I saw those sites, like freewarefiles, but I do not trust them, I guess that I’m as paranoid as @sampattuzzi with nullptr verification. In any case I guess that the usage of that example in the course is purely anecdotic, since apparently it was only shown once, so I guess that if it cannot be solved with the current Windows SDK, I’ll pass from building it.
P.S: I also asked steam about it but I’m still waiting for a response. They don’t seem to care much about that example.

I would have preferred to get the file directly from microsoft as well but I grabbed the version from archive.org. They are a well known and trustworthy organization, and I ran a virus scan on the installer and it came back clean.

1 Like

Thank you @geminfry, if Steam doesn’t give me a valid solution with the Windows SDK and I feel really curious about their example, I’ll try with the archive.org file.

This topic was automatically closed 24 hours after the last reply. New replies are no longer allowed.