Cannot Create Third Person Project - Error

When I try to create the new project in Unreal, using the Third Person as a template, I get the following error:

The project could not be compiled. Would you like to open it in Visual Studio Code?

clang: error: no such file or directory: ‘/System/Library/PrivateFrameworks/MultitouchSupport.framework/Versions/Current/MultitouchSupport’

I try to open the visual studio file and compile within Visual Studio and receive the following compile error:

" The preLaunchTask ‘MyProject Mac Debug Build’ terminated with exit code 6."

I have no idea what is going on with trying to create this project… All of my other projects work fine still. I have tried in both 4.25.4 and 4.26, with the same error. Any help would be appreciated!

I know this one, In fact, I encountered this yesterday. Are you using MACOS BigSur? Because they moved where the Multitouch support file is… and that causes a TON of crashes. But 4.26 should’ve fixed it.

Thanks for the reply!!

Yep I am using Big Sur for sure. I tried uninstalling/reinstalling 4.26 to see if that fixed it, but no luck. That’s when I went back to 4.25.4 to see if that fixed it, but again, no luck.

Any tips for what you did to fix it? Or was using 4.26 enough?

Thanks again!

4.26 should’ve been enough, as the engine code was modified to accommodate BigSur, let me see if I can find the GH commit, but they changed 2 lines of engine Code and it worked.

Edit: here

My suggestion: try creating a blank project and see if it works. Also check Xcode version, since you’re using bigsur, you should have Xcode 12+

I just tried to create a blank project, and this is what I got (slightly different):

The project could not be compiled. Would you like to open it in Xcode?

Running Mono…

Running bundled mono, version: Mono JIT compiler version 5.16.0.220 (2018-06/bb3ae37d71a Fri Nov 16 17:12:11 EST 2018)
~/Library/Application Support/Epic/UnrealEngine/UE_4.26/Engine ~/Library/Application Support/Epic/UnrealEngine/UE_4.26/Engine/Binaries/Mac
Creating makefile for PuzzlePlatformEditor (no existing makefile)
ERROR: Could not find definition for module ‘’, (referenced via Target -> ActorSequenceEditor.Build.cs)

hmm… That is very weird

I’d probably just plug the error log stuff into google and see if anything good comes up. Sorry, but I’m not too sure what’s happening either then. I thought it’d just be the Multitouch thing causing issues

Totally understand. I appreciate the help!! I’ll keep searching around…

Thanks, Goodluck!

What version of Xcode are you using?