Build Resolution

Whenever I build the game in windowed mode, regardless of my settings it still pushes out a 1920x1080 window and as such the UI matches to fit that and the background does not fill the space and so the player can see the default Unity background. How do I fix this?

Hi Daigus,

If you changed the resolution in the Build/Player Settings but the build always gets a resolution of 1920x1080, it might be that this resolution is stored in the PlayerPrefs.

If you cannot find any option for ‘Delete PlayerPrefs’ in the menu, write a new script with PlayerPrefs.DeleteAll();, for example, in Awake() or Start().

Add your script to a game object, start your game. Stop your game again. Then remove the component, and build your game again.

Did this fix it?

See also:

This topic was automatically closed 24 hours after the last reply. New replies are no longer allowed.

Privacy & Terms