Autofill not working in visual studio code

Hi.

My vs code is not helping with autofill. I already saw another question about the same topic here but it didn’t help me. When I open vs code it doesn’t even have any errors!

Hi Otso,

Welcome to our community! :slight_smile:

I do not know what you already tried, so here is my default answer:

Please follow the instruction on this website and make sure all required extensions are installed: https://code.visualstudio.com/docs/other/unity

If the issue persists, please check the console of VS Code (not Unity!). If the .NET Framework 4.7.1 (Developer Pack) is mentioned there, download and install it from the official Microsoft. Here is the link: https://dotnet.microsoft.com/download/dotnet-framework/net471

Depending on your version of Unity, it might be that you will have to install the “Visual Studio Code Editor” package in Window > Package Manager in Unity.

Maybe you’ll have to reboot your computer. Then launch Unity again and open one of your scripts.

And you could try this:

  1. Press Ctrl + Shift + P.
  2. Type “OmniSharp: Select Project” and press Return.
  3. Select the solution workspace entry.

If nothing helped, install and use Visual Studio (Community Edition). For some students, VS Code simply does not work well. Maybe due to a problem with Unity, some update or whatever.

  1. Install VS.
  2. Select it as your External Script Editor in Unity (Edit > Preferences > External Tools).
  3. Install the “Visual Studio Editor” package in the Package Manager.

That should work.


See also: