After I change my scene to render flat polys, everything is too dark

I have a low poly landscape I created while watching “Lecture 103. Flat Shading Low Poly Landscapes.” I have painted it as instructed, and after the lighting builds it looks fine. But when I hook up the Cross Product output in the Landscape material to the Normal hook in the Landscape node (shown) it becomes too dark. I can’t figure out what to change to get it to be visible.

I am using Unreal Engine 4.14.1. The ONLY thing I am changing between the screenshots before is the hook in the Landscape material. Any suggestions on what to try?

(I can only put one image in a post so I can’t show the before in this post. I can post later if needed)

I’m having the same issue in 4.14.2

Do you have your project on github?

Ah yes. Code can be found here:

I noticed the same behavior originally in unreal engine v4.14.1, then re-started the project in v4.12.5 where I still see the same behavior.

I cloned your repo and it doesn’t look like your screenshot to me, there were random blackspots though. However resetting the landscape material and reapplying seemed to have fixed that. Though there were some rather drastic shadows so maybe adding a directional light to tone that down would help.

I found that DDX must be used for A, and DDY must be used for B, swapping them will give you the error.

I use Unreal 4.14 and I have noticed, often the lighting, or parts of it, just disappears at random times. The only solution is rebuild lighting and it usually comes back. There’s a bug somewhere in the Unreal code, I think.

Thanks for the replies everyone, and thanks for taking the time to review. The project was saved and committed with the flat shading disconnected (turned off). To replicate, you would need to open the Battleground_sharedassets/Landscape blueprint and connect the output of the “Cross” element to the Normal input of the “Landscape” element. When I do this and re-build the lighting, it all turns dark as in the first pic.

Here is what the connection should be to replicate:

How are you getting on with this?

What light(s) do you have in your world (I haven’t yet taken the time to download your project)?

Have you tried a different rotation for the sun?

Do you have any unusual scaling applied to your landscape?

Have you tried try clearing the derived files like this…

  1. Close Unreal and Visual Studio
  2. Delete the following folders: Binaries, Build, Intermediate, Saved
  3. Delete the Visual Studio or Xcode solution file (.sln or .xcodeproj)
  4. Re-open Unreal

Good luck!

Again, resetting the material of the landscape to the default and then setting it to your Landscape Material fixed this issue. You would need to work with your lighting still since you have extremely drastic shadows.

Thanks everyone for all the suggestions, I have found the fix! Resetting the Landscape material did not change anything for me, nor did rebuilding the project or changing the Sky Sphere.

It turns out that swapping the A and B inputs to the Cross Product solved the issue. I see that ForrestS mentioned that, but in my case I have to connect DDX to B and DDY to A. I’m sure I could spend some more brain cells trying to figure out why my setup needs the opposite connection, but for now I am happy to move on!

Thanks again.

ah…so I guess normals were pointing the wrong way (swapping inputs to a cross product will cause the result vector to point the other way).

Privacy & Terms