Adding button to canvas not showing in scene, but is showing in game

I am adding the canvas as per usual. I then right-click on the canvas, go to UI, and click on button. It is showing in my Game section, but not in the Scene section. Changing the size affects it in Game, but nothing still shows up in scene.

I’ve tried closing and reopening the file. I’ve tried changing the screen scaling. I tried making a new file from scratch. None of these seem to be fixing the issue.

Any help would be greatly appreciated. Running Unity 2019.4.18


Please go to the top right corner of Unity, click on “Layers” and make sure that the UI layer is enabled.

Did this fix it?

See also:

It did not. I also tried upgrading to 2019.4.19f1 to no avail. See attached picture that shows the layer is visible.

The screenshot is very helpful. Thanks for sharing. It shows the camera viewport, not the Canvas box. Double click on the Canvas game object in your Hierarchy, alternatively on the Button.

1 Like

It took bouncing back and forth a few times between both, but they eventually showed.

This topic was automatically closed 24 hours after the last reply. New replies are no longer allowed.

Privacy & Terms