Xcode GameAssembly Command PhaseScriptExcuction failed

I have tried everything, I’ve search online and it tells me to delete and reinstall pods. I try and find pods to do this I have none, I try to download to see if it will fix it, it tells me I don’t have permission through ruby. I try 30 other videos and ways to maybe get this code to go away but I can’t. Please help me understand this, all I want is to be able to convert my games to IOS to also release them on the apple store but I’m about to give up on apple and only work with androids.

There could be a number of reasons other than Pods causing this error.

Ensure your project settings in Unity are correctly configured for iOS:

  1. Target Platform : Make sure your target platform is set to iOS in the Build Settings.
  2. Scripting Backend : Check that the Scripting Backend is set to IL2CPP in Player Settings.
  3. Architecture : Ensure the architecture is set to ARM64.

Have you also tried a clean build?, I have had a problem with risidual files causing issues?
Do both in unity and xcode .

As for pods you say you have none, and you cant install which way did you try and do this?

  • Navigate to your project directory in the terminal.
  • Run pod install to ensure all dependencies are correctly installed.
  • Ensure your Podfile is correctly configured.

and other than that did you try reimporting you project back into Unity and Xcode?

Can you also paste the error log, if none of these fixes work

Unfortunately, I’m not in a great position to help out on this one.
In order to build to iOS, all that XCode stuff has to be done on a Mac (and a relatively new one). Confession: Nathan actually borrowed one for the course. I don’t have access to one.

If @LaniganDev’s suggestions don’t work, I suggest heading to the Offical Unity Forums

Privacy & Terms