Why not name variables OUT_ instead of macro or comment?

I get the point of marking out parameters somehow and from previous posts it’s clear that a comment works as well as an empty macro. My question: Is there a reason we dont just name our out variables OUT_SomethingDescriptive?
It seems simpler and since it’s in the name you cant really miss marking them if you use them later on.

I also prefer naming my Variable OutParameter. No need for that OUT macro.

That’s also part of Unreals coding standard to prefix output parameters with Out i.e. OutHitLocation

Privacy & Terms