Why doesn't VS Code update?


In VS Code I keep on getting prompted to update:

When I click “Restart to Update” VS Code shuts down and begins updating. A few minutes later I get this error:
The strange thing is that no instance of VS Code is open when it is updating, so I don’t know why it would say that “it is being used by another process.”
If I click retry, the same error appears. If I click cancel, this message appears:


I’ve tried searching online for the error code vscode-inno-updater-1564845010.log means, but I haven’t been able to find anything. I do have Malwarebytes installed on my computer, so I could try uninstalling it…

In the meantime, VS Code continues to work but I wouldn’t want the program to not be able to update.
Any help is appreciated.


It should be exactly as the error states, something is still doing something with it. No one here knows exactly what’s on your computer so we have more guessing than you do.

You should be able to disable Malwarebytes temporarily https://forums.malwarebytes.com/topic/206283-how-do-i-temporarily-disable-malwarebytes/

Today with everything there is, you might be able to find something, an application even, that can tell you what’s using it.

But you could also try a reboot if you didn’t. Sounds like you didn’t. Reboots can solve a lot of things.

And last but not least, uninstall and reinstall of an updated download of VSC could do the trick too but its the long way around.

Thanks, I somehow got it to work! After I restarted, VS Code opened by itself and said it had updated.


1 Like

This topic was automatically closed 24 hours after the last reply. New replies are no longer allowed.

Privacy & Terms