Why does VSCode autocomplete remove the first character of the method?

When using the autocomplete for the method (as seen in the video for _PhysicsProcess)

it autocompletes which is good, however it removes the ‘P’ from the start ? Is there anyway to fix this ?
Its super frustrating.

I’ve never used VSCode myself, but the consensus across several topics I’ve seen regarding VSCode seems to be “switch to an IDE that isn’t broken and save yourself a giant headache.”

See this topic:

I use VSCode daily for work with python and havent had any issues, i guess it is just broken with C#

Ah, then I can appreciate how this would be even more frustrating for you. Collecting IDEs like loyalty cards isn’t ideal. Best of luck; if you find a solution that works for you, I hope you’ll share it so others can benefit =)

It happens throughout the course aswell but the instructor seems to just ignore it and correct it everytime, its a fun one.

Which IDE do you use for C# that you would recommend ?

XD

I haven’t used C# in years, but I always used the proper Visual Studio Community, all the way back to VS2005. That would be my first go-to (even if it’s not the latest version), as I never had any code completion issues with that.

I’ve also only ever head good things about Rider, but since that’s a paid option, I’d only go with it as a last resort. Not familiar with any of the other options I found in a quick search, apart from Notepad++ which I’ve never tried with C#. If you choose something other than VS Community and find a hidden gem, I’d love to hear about it!

VS Code can work. The team I work with mostly uses it but I use Clion which is an option for C++ for unreal. It’s unstable because of the Pc at work setup but works well and in some ways VS Code works better than it, others not so much.

I’ve never even tried to get vs code working for unity or unreal simply because I’ve got rider and had it for so long now. The main advantage for me of rider is it works with Unity and Unreal both and offered very similar features to VS community but resharper with VS community doesn’t work well with Unreal anyway.

VS Community is what I used for a long time but then rider was made available as part of resharper and then they added C++ support. It’s a great tool for Windows.

There’s not many others out there I would consider. Mac and Linux users are limited. XCode or vs code really for the mac, and rider or vs code for Linux. It is why they use VS code in the courses although saying that some of the newer UE courses have gone back to VS community.

That’s my 2c worth. I’d steer people away from vs code on windows anyway.

I remember there used to be monodevelop which was bundled with Unity but not sure if it is still a thing.

1 Like

Updating the C# extension in VSCode to the pre-release version has solved this annoying issue luckily.

2 Likes

Appreciate the heads up and i was having an issue with it doing that to the _Ready and constantly removing the R as well.
Looks like its something they are aware of and are fixing in a future release

1 Like

Privacy & Terms