Why do objects appear black or weird in LookDev/Render mode?

What the title says. Here’s some images. I’ve tried searching the Blender forums and this community for ways to solve this, but I just can’t figure out what the problem is. Also, I can’t seem to replicate this issue on 2.7.

13LookDev Mode

22Solid Mode

32Render Preview Mode

**EDIT: **

When in LookDev mode, the issue becomes less apparent if I toggle the “Scene Lights” option on the Shading Menu. Doing this makes my scene actually appear, instead of just having some black blobs over a grey background.
38LookDev Mode with Scene Lights option toggled On

With this, it seems to me Blender isn’t loading/showing materials, and that the native lighting map on Eevee isn’t working, given that it is necessary for me to turn on Scene Lights in order for my scene to have lighting. Playing around with nodes on the Shading tab does nothing. Neither does switching over to Cycles (in fact, this seems to exacerbate the problem).

This what the HDR and Texture orb thingies look like on the Shading Editor:

EDIT 02/25/18: The issue has been solved with the newest updates. Textures and HDR load correctly now.

Could you upload the blend file and have you tried updating the blender version you are using?
I’ve not encountered this so it may be worth checking for gpu driver updates as well just in case.

Sorry for the wait in the reply and thanks for the prompt, Looks like i viewed but forgot to come back and reply to this.

Hi! Thank you so much for answering!

Here’s the .blend file:
DuplicationChallenge.blend (897.2 KB)

I’m using the Blender 2.8 beta from February 15.

I don’t actually have a GPU. It’s integrated graphics. Could that be part of the problem?


I would double check for an updated version of blender 2.8 first but its likely that is the issue and you may need to get a dedicated GPU to use blender 2.8 which i can appreciate is not easy if its a laptop.
I have checked the blend file on my version and lookdev works fine with the file so its not the blend file itself.
Mine also displays the HDRI correctly so i am thinking that it doesnt support this.

Hope you find a solution from this

Thank you! If i come up with something i’ll let you guys know.

1 Like

This topic was automatically closed 24 hours after the last reply. New replies are no longer allowed.

Privacy & Terms