Why Do My Render Preview And Rendered Image Look So Different?

So my prerender looks great but then my rendered image has this weird light on the rock that I’m not sure why its there. Is there any way to fix it?


There may be some objects in the render that are not meant to be there. Specifically, in the top right where you can see a list of your objects in the scene (the Outliner), next to their name there is a symbol of a camera. When clicked, the camera will be greyed out, meaning that it won’t show up in the final render.

It appears that the extra light source is hidden from your viewport, but not the final render. I hope this helps. If not, please let me know and I’ll think of more solutions. :+1:


If you mean the whiter rock it is an object that is hidden in the viewport but not from the render.

You also have a light in the ‘Collection’ that is similarly hidden in the viewport so doing nothing but not hidden in the render so adding light to it.

1 Like

Is there a way to hide it from both the view port and the render? It was a backup of the rock just in case I somehow messed it up. I ended up deleting it once I came to that realization, but was just curious to know if there’s a way to still have it there without it showing up in the render for the future.

1 Like
  1. turn on and off the selection ability

  2. Hide in the viewport

  3. Dissable in all viewports

  4. Hide to the render

  5. Is where you find and add any of those icons you do not have showing.

So to hide in viewport and render click and turn grey 2 & 4.


Oh thank you so I’ve added the two I was missing in and will bookmark this for future reference.


This topic was automatically closed 24 hours after the last reply. New replies are no longer allowed.

Privacy & Terms