Why did Ben have us track 700 MB of Starter Content?

Seriously this was extremly annoying. I couldn’t get the source tree program to stop trying to upload the starter content. I changed the .gitignore and made a new branch, then unselected master branch to push, but it still was uploading starter content. I had to make a new project from scratch because of too many program complaints, had to figure out how to delete the existing one from source tree, ect. , all too go back to the old way of doing things. I guess I wont be exploring unreal’s built in source control for now, because of the mess that was assosiated with it from ben’s misleading.

Looks like submitting to source control freezes unreal editor anyway

It’s seems when you create a Source Control on the Unreal they Stage All files including the StarterContent, so in the SourceTree instead of commiting righ away, you unstage all the files and put the StarterContent on gitignore.

1 Like

Hmm ok interesting. Hey do you have any idea why my source tree isn’t logging in to push the files?
I have correct login but keeps giving me error.
Anything I’m doing wrong here?

Says Valid authentication but still comlains when I push.
I reset my password to ensure it should be working. And refreshed authentication and tried every protocall aswell …

Im just returning to unreal and source tree after quite a while now. But don’t see why this should be an issue.
Can login fine to github.com

Hmm … Strange, I had no problem with authentication, I’m using the HTTPS and everything went well. You can try generate an OAuth Token instead of basic authentication. I have no idea how to solve this.

1 Like

I wonder if its a problem with my internet or computer. I get wierd lagouts from certain elements of certain services sometimes. (like recieving notifications from facebook messanger without being able to load the messanger or facebook itself)

When i try to refresh OAuth Token sometimes it says it fails and sometimes it says OK. Even tho it keeps telling me my connection was reset when i access the page after github site loads with HTTPS,

the url says authenticated

With SSH it brings me strait to the connection connection was reset page every time. But … seems to be authenticating source tree at least most the time.

Some bizzare stuff …

did you solve the problem?

It appears to be an issue with the version of Source control and git that it is using… There were a few things that I did to solve this. The first was to install the most recent version of Git on my system and use it as opposed to the embedded Git files in the Git tab. Additionally, in Network, I Enabled TLS 1.2. Finally, I deleted the authentication data from my computer for both Github and Sourcetree (as seen under Control Panel -> Users -> Manage Credentials-> Windows Credentials), as well as the passwrd file in the …/AppsData/Atlassian folder. The links were I found this information are below:

This worked for me, and I hope that it helps someone else!

Privacy & Terms