When I refactored, I created a GetReachLineEnd() since it was clearly needed.
However, I didn’t bother creating a GetReachLineStart() as I could accomplish the same thing with the following function call that could be used anywhere that the method was called: “GetOwner()->GetActorLocation()”
I added GetReachLineEnd() to keep my project in parity with the course (sometimes valuable lessons are non-obvious for future lectures, so I generally follow the instructions while preserving my own attempts commented out for future reference). In this case, my GetReachLineEnd() method simply returns “GetOwner()->GetActorLocation()”.
I understand the need for clarity, but “GetOwner()->GetActorLocation()” seems self-explanatory when used in-line. And it seems cleaner than using 2 variables to call a function with extraneous return data. I am using Unreal 4.17, so I don’t know if the GetActorLocation() function was added sometime after 4.10 (used to create these lectures).
Am I missing something? Or is this simply a difference of style/preference?
Thanks!