When creating a Vector2 for paddlePos and assigning the paddle’s position, is there a reason we are using…
Vector2 paddlePos = new Vector2( paddle01.transform.position.x, paddle01.transform.position.y);
instead of just using…
Vector2 paddlePos = paddle01.transform.position;
both seem to work fine at this stage but not sure if the shorter one will create problems later on, I doubt it will but I don’t want to assume.