While doing Crystal Cavern

My BP_Player pawn won’t always take damage only if it gets hit at a certain angle how can I fix this please.

I had this same problem. Sometimes the ball received the damage and sometimes it just bounced off the projectile. Not sure if this is the best way but here is how I fixed it:

  • Open BP_Projectile.
  • Select the Static Mesh component and set Collision Presets to NoCollision.
  • Select the Sphere Collision component and set the following properties:
    • Collision Presets: Custom
    • Collision Enabled: Query Only (No Physics Collision)
    • Object Type: WorldDynamic
    • Collision Responses: Block (all the column will set to “Block” automatically)
1 Like

How would I set an emitter to only emit particles every 5 seconds in Blueprint?

You can fix it by following Marble Run Video “Convert BSP to Static Mesh” and setting up the Static Mesh as “Block All” and “Generates Overlap Event”. In BP_Projectile you have to change the “Event Hit” to “Event Actor begin Overlap”. Done.

EDIT: AND you have to set the BP_Projectile to “Overlap All”!