Whats wrong with GODOT?

I tried to import Tom into Godot, but this is result, whats wrong with asset?

Updated Thu Jan 11 2024 21:27

1 Like

Hi Filip,

Godot does not natively support FBX files and that is probably why you are getting the distortion on the mesh with the rig.
I would try exporting as the glb/gtlf format and see if that yields the more require results.

Its been a very long time since i did this but my initial tests seem to work with this format.

Good luck and let us know how you get on


Moving this to the blender section of the forums for better exposure (though admittedly this question is a bit of a grey area)


I know nothing of Godot, but I always thought the point of it was native support for blend files.
So a quick google came up with this.

Importing .blend files directly within Godot

Available 3D formats — Godot Engine (stable) documentation in English.

You will probable understand it more than me. Hope this helps.


Using glb format works well or you can use FBX2glTF (see Editor menu, Configure FBX Importer) but why bother when glb works!

I imported the separate animations and saved them as resource files, see Save to File in Import Settings for each animation imported and then added those to an animation library. In animation window, click Animation, Manage Animations and Add Library, you can then add each animation to the library. There’s possibly an easier way as I’m no expert but that worked for me.

1 Like

Privacy & Terms