Weird Normal Map for Baking

When I bake the normals and plug it into the shader, it looks really low in resolution, and quality. It’s a got a 2048 resolution, there’s very minimal stretching, and I think the topology is pretty good. They’re both shaded smooth, and their normals are good, I just don’t know why it’s looking like this :thinking:.
Any help would be much appreciated , Thanks!
Ogre Snip


1 Like

You cut off all the panel info and UV map, image etc.
You seem to have checked the obvious.
We need to SEE more.

Baking checklist.
HP= High poly model baking the details from.
LP= Low Poly model baking details to.

Check normals on Both models are all correctly outward facing.
Check both share the same place for their origin points.
Make your LP a ‘reasonable’ fit to the HP.
UV unwrap the LP

Smooth shade BOTH models.
Select the HP first, then the LP so the LP is the active selection.
Set to Cycles render engine.
Ensure Rendering of the objects involved is not turned off, (camera icon in outliner)
Create a new blank image In the Image editor, Name it with an appropriate ending, like norm, diff, ao, rough, etc.
Create a material for your LP object. (if it has not already)
Open that new blank image in an image texture Node of the LP material.
The Image texture Node does NOT need to be connected.
The Image texture Node MUST be selected.

In the Render Properties tab. Scroll down to the BAKE dropdown.
Change the Bake Type to the one you wish to do.
In the Influence dropdown, untick Lighting Direct and Indirect.

TICK the Selected to Active Box and open the dropdown.

The Messing about part.
Set extrusion to 0.002 As a first test, these numbers will vary by model and HP/LP fit.
Set Max Ray Distance, you can probably leave it at zero. But again it is a number that may need adjusting to your use case.

Play with these numbers until you get a good result. This bit is not a matter of using X and Y numbers as every model varies. It often needs several tries to find a good pair of values.

Output, will be Image Textures.
Tick the Clear image box to bake over anything on the new image file, like a previous try that did not work quite as wanted. (Untick it if baking multiple objects to one map, otherwise, it will clear away previous baked info on the image.)

Margin size, 20px should cover most likely eventualities

You are set. Make sure the models are selected in the right order, and that the image node being baked to is actively selected.

Click Bake! Wait.
Grant mentions at one point ‘So if there’s any glitches in your normal maps or cavity maps that you can’t figure out, then change the device back to CPU and it may work.’


Thanks for the reply! I guess I had the order wrong, I did the Lp first and Hp second, but when I choose Hp first and Lp second, and click bake it says: No Active Uv Layer found in the object “Ogre High Poly”.

Here’s my Uv unwrap:
Both Lp, and Hp together:

That suggests you had not got them selected right, or the image node was not selected to bake to possibly.

I just got it to work :partying_face:. I just took it to a fresh new scene, and applied all the stuff I needed to do, and it worked!

1 Like

Great to hear.

1 Like

This topic was automatically closed 24 hours after the last reply. New replies are no longer allowed.

Privacy & Terms