WebGL not uploading

I have been waiting for the upload to sharemygame.com for 20 minutes and then did an upload refresh. I am still waiting. I noticed that the FAQ listed uploading using Chrome or Firefox. I am using Microsoft Edge. Is this the problem?

Thanks

Hi Richard,

Could you share the link to your game?

It might be that the website is not optimised for MS Edge. Test your game with a different browser.

Thanks for the reply. I cannot share the link to the game because the game upload is stuck on the UPLOAD page. This is a link to that page but I don’t think that will help you. I have tried to do this both in Microsoft Edge and the latest version of Chrome.

I have tried multiple times to upload it and all I get is the upload page saying: CONGRATULATIONS your upload is pending.

And there I wait.

The game plays on my PC build just fine.

Somehow I got my game showing on gameshare and there was a warning note in red:

saveUnityUpload:TypeError: Cannot read property ‘UNITY_WEB_NAME’ of null at module.exports (/workspace/src/saveUnityUpload.js:42:55) at process._tickCallback (internal/process/next_tick.js:68:7)

Other than that went I go back to my hme page in sharemygame.com it shows that I have NO uploads.

I appreciate your help. I have also contacting Support at SIMMER and they are aware of my problem.

That’s probably the best because I cannot help with technical issues on other websites.

If you uploaded your game and the webpage says the upload was pending, it’s probably not an issue with your browser. The simmer.io server often has got issues during holidays when many people try to upload their projects.

Thanks for the information. I thought as much myself. I hope I will be able to eventually post my game on their site so it can be shared with this community.

How are you getting on with this, Richard? Were you able to upload your game? If not, I’d suggest to upload it to another website such as itch.io.

I got a note from Sharemygame and it said my upload was successful and my game was online. I checked it out and it doesn’t load from Microsoft Edge or Chrome. But, I tried in FireFox and it loaded and works. I don’t know why it only works in FireFox but so far that is the only way I can play it online. I don’t know if it works for anyone else. I did post the link to my game in the community but have gotten no responses yet.

Here is the link if you would like to check it out. And thanks yet again Nina.

I tested your game in Chrome, and it is working.

Are you able to play other people’s games with Chrome? If so, check if you have any script blockers (e.g. addons) active. If you are getting any error messages, for example, that Chrome was not able to run WebGL, enable WebGL in your browser settings.

I did what you described on Enabling WebGL in Chrome and it still did not work for me. I have no add ons that I am aware of either (at least any that I added myself).

In that case, use Firefox to play games. Alternatively, uninstall Chrome and install the latest version. Maybe that’ll fix the issue.

I will give that a try. I did check with some friends and they were able to play my little game using Microsoft Edge. I can’t do that either so there must be something on my computer blocking WebGL.

Again thanks for the suggestion.