WebGL Build Fail

Hi apelpapa,

Welcome to our community! :slight_smile:

Where did you try to save your build? In a separate folder and not inside your project folder, on the Desktop or in a cloud? If so, maybe the problem is the path. Make sure not to have any “funny” characters in the path name because Unity cannot process those characters properly. APELS~1 could be causing the issue.

Before you tried to build your game, did you see any error messages in your console?

1 Like

I did try to save the build to the desktop. I am not sure where the APELS~1 is coming from, my windows username is Apel’s Home Computer, could the apostrophe or spaces be causing the issue?

The apostroph might be a “funny” character. Don’t use it in folder/file/path names because you could get unexpected errors. Ideally, use A-Z, a-z, 0-9, underscore, minus and dot only. Spaces might or might not cause issues. That depends on the software. I haven’t encountered any issues with spaces in the context of Unity yet but many issues with, for example, German, Spanish, French and Chinese characters.

As you can see in your screenshot, the apostroph seems to be converted to “~1”. It might be that something else reads “~1” but doesn’t interpret it as an apostroph. In that case, the APELS~1 could not be found because it does not exist.

Computers are unpredictable in this respect.


Created a new user with no apostrophes or spaces and it worked. Thank you!

This topic was automatically closed 24 hours after the last reply. New replies are no longer allowed.

Privacy & Terms