Warehouse - main directional light - scene rendering

Does anyone know why the main directional light in the scene goes straight through the walls/ceiling and flood lights warehouse interior?

1 Like

Have you blocked out the light? The meshes are likely see-through.

1 Like

I also had some issues with the lighting. It’s probably something like DanM says that some settings are wrong, making it so that the light ignores the walls. I have not taken the time to learn about Unreal’s lighting system, and my solution is probably not the best way to do it. I also want to add that I’m using Unreal Engine 5.1, so there might be some differences depending on what version you are using.

Anyway, this is what I did:
I clicked on the lighting in the outliner to see the details.

In the Transformation section, just below the scale, is the option to set the mobility of the lighting. It should be set to movable by default. I set it to stationary.

I did the above for every light source, and then I went to the menu bar and clicked Build->Build Lighting Only.

I also want to add that I had some issues with the auto exposure and ended up disabling it following this video: https://youtu.be/kNeM_6TWF6c (for Unreal Engine 5.0 follow this: https://youtu.be/0etGOh-USrQ)

I hope this helps you.


This topic was automatically closed 20 days after the last reply. New replies are no longer allowed.

Privacy & Terms