Vs code compile

I’m compiling while watching the lecture, but I keep getting errors. MovingPlatform.h is as follows.
// Fill out your copyright notice in the Description page of Project Settings.

#pragma once

#include “CoreMinimal.h”

#include “GameFramework/Actor.h”

#include “MovingPlatform.generated.h”


class OBSTACLEASSULT_API AMovingPlatform : public AActor




// Sets default values for this actor's properties



// Called when the game starts or when spawned

virtual void BeginPlay() override;


// Called every frame

virtual void Tick(float DeltaTime) override;


The problem is not compiled here. Moving Platform.h is written in red with a 2 next to it.

When you perform a build operation, it appears as follows (the following are some of the terminal’s contents)

c1xx: fatal error C1083: 컴파일러 중간 파일 파일을 열 수 없습니다. ‘C:\Users\諛뺤꽭鍮?OneDrive\諛뷀깢 ?붾㈃\援щ쫫?몃━??ObstacleAssult\Intermediate\Build\Win64\x64\ObstacleAssultEditor\Development\Engine\SharedPCH.Engine.Cpp20.InclOrderUnreal5_0.h.pch’: Invalid argument

It says that I can’t find the file when it is displayed like this, but why can’t I find it? Or is there another reason?

Since it’s my first time writing, I might be inexperienced. Also, since I am using a translator, the sentences may not be smooth. Please, please

It’s likely due to the non-English characters in the path to the project.

Thank you for your reply.
The laptop itself is set to Korean from the beginning. My name and documents are in Korean. Will this be resolved if I change it to English?

If that also changes the path to only contain English letters.

I’d suggest moving it to a different folder only containing English letters, if only to test to see if that’s the issue.

I moved it to a folder with only English. The terminal appears as below.

  • 폴더 UE_5.3에서 작업 실행 중: Engine\Build\BatchFiles\Build.bat ObstacleAssaultEditor Win64 Development “C:\unreal\Unreal Projects\ObstacleAssault\ObstacleAssault\ObstacleAssault.uproject” -waitmutex

Using bundled DotNet SDK version: 6.0.302
Running UnrealBuildTool: dotnet “…\Engine\Binaries\DotNET\UnrealBuildTool\UnrealBuildTool.dll” ObstacleAssaultEditor Win64 Development “C:\unreal\Unreal Projects\ObstacleAssault\ObstacleAssault\ObstacleAssault.uproject” -waitmutex
Log file: C:\Users\박세빈\AppData\Local\UnrealBuildTool\Log.txt
Building ObstacleAssaultEditor…
Using Visual Studio 2022 14.38.33135 toolchain (C:\Program Files\Microsoft Visual Studio\2022\Community\VC\Tools\MSVC\14.38.33130) and Windows 10.0.22621.0 SDK (C:\Program Files (x86)\Windows Kits\10).
[Upgrade] Using backward-compatible include order. The latest version of UE has changed the order of includes, which may require code changes. The current setting is:
[Upgrade] IncludeOrderVersion = EngineIncludeOrderVersion.Unreal5_0
[Upgrade] Suppress this message by setting ‘IncludeOrderVersion = EngineIncludeOrderVersion.Latest;’ in ObstacleAssaultEditor.Target.cs.
[Upgrade] Alternatively you can set this to ‘EngineIncludeOrderVersion.Latest’ to always use the latest include order. This will potentially cause compile errors when integrating new versions of the engine.
Determining max actions to execute in parallel (4 physical cores, 8 logical cores)
Executing up to 4 processes, one per physical core
Requested 1.5 GB memory per action, 1.77 GB available: limiting max parallel actions to 1
------ Building 9 action(s) started ------
[1/9] Compile [x64] SharedPCH.Engine.Cpp20.InclOrderUnreal5_0.cpp
[2/9] Compile [x64] ObstacleAssault.cpp
[3/9] Compile [x64] ObstacleAssault.init.gen.cpp
[4/9] Compile [x64] MovingPlatform.cpp
[5/9] Compile [x64] MovingPlatform.gen.cpp
[6/9] Resource Default.rc2
[7/9] Link [x64] UnrealEditor-ObstacleAssault.dll
C:\unreal\Unreal Projects\ObstacleAssault\ObstacleAssault\Intermediate\Build\Win64\x64\UnrealEditor\Development\ObstacleAssault\UnrealEditor-ObstacleAssault.sup.lib 라이브러리 및 C:\unreal\Unreal Projects\ObstacleAssault\ObstacleAssault\Intermediate\Build\Win64\x64\UnrealEditor\Development\ObstacleAssault\UnrealEditor-ObstacleAssault.sup.exp 개체를 생성하고 있습니다.
[8/9] Link [x64] UnrealEditor-ObstacleAssault.lib
C:\unreal\Unreal Projects\ObstacleAssault\ObstacleAssault\Intermediate\Build\Win64\x64\UnrealEditor\Development\ObstacleAssault\UnrealEditor-ObstacleAssault.lib 라이브러리 및 C:\unreal\Unreal Projects\ObstacleAssault\ObstacleAssault\Intermediate\Build\Win64\x64\UnrealEditor\Development\ObstacleAssault\UnrealEditor-ObstacleAssault.exp 개체를 생성하고 있습니다.
[9/9] WriteMetadata ObstacleAssaultEditor.target
Total time in Parallel executor: 113.44 seconds
Total execution time: 114.95 seconds

  • 터미널이 작업에서 다시 사용됩니다. 닫으려면 아무 키나 누르세요.

I don’t think there is any error. It didn’t go into Unreal earlier, but now it goes in.

But I don’t see any other projects on Epic Games or Unreal other than the current one. It’s on my laptop, but it doesn’t come up on Epic Games. Is there any way to fix it?


Is that after opening them in Unreal?

Above, this is a photo opened by Epic Games. Neither Epic Games nor Unreal can see previous projects. Only projects are currently coming out. Now that I checked, There are no projects in Unreal. There is neither a current project nor a previous one.

The sentence might be strange because I wrote it in English through a translator.

I think you might have misunderstood?

If you open each of the project by double clicking the uproject or from the Unreal Editor by using File > Open Project > Browse > then navigating to and selecting the .uproject for a given project; does it then show up in the launcher?

Is it right to find my project on Unreal and open it? If this is right, I’ve already tried it, but it didn’t appear on Unreal.

Have you tried this?


C:\Users[사용자 이름]\AppData\Local\EpicGamesLauncher\Saved\Config\Windows

I searched for appdata on users to get here, and there are several appdata. I went into several appdata one by one, and I found Local, but I couldn’t find EpicGamesLauncher. I don’t know if my method is wrong…

I’m sorry that I can’t keep up with you despite your consideration.

This topic was automatically closed 24 hours after the last reply. New replies are no longer allowed.

Which part did you get up to? Do you have an Epic Games Launcher in your local AppData? Could you show the last part you got to?

I’m sorry for sending it late.
There’s an office within the local, and within 16.0, there’s Floodgate and WebServiceCache. There’s nothing in Floodgate, but WebserviceCache has AllUsers, and within that, there’s officeclient.microsoft.com . And within that, there’s a file like this: 1AE851D4-D68D-42C5-AB8D-509248FC5438.

Don’t search for the folder, paste it directly into the address bar

My project will now be on Epic Games. Thanks to you, I was able to solve it well. I’m sorry to ask you such a long question.

1 Like

Don’t worry about it, happy to help :slight_smile:

1 Like

This topic was automatically closed 24 hours after the last reply. New replies are no longer allowed.

Privacy & Terms