Visual Studio Wont Display "dots"

Literally Visual Studio suddenly decided it wont display “.” (a dot) when I press it on the key board, this happens in every .cpp and .h file in the entire project, but if I place a random dot in the code even if Visual Studio isn’t displaying it if I go compile it the editor throws an error say hey there’s a dot that doesn’t belong but i can type a dot in any other application. However if I open Visual Studio directly from my desktop and just create a blank .cpp file I can type all the dots I want with no error so this makes me think it is local to the project for some reason. I confirmed this by opening my Building Escape project and opened “grabber.cpp” and was also able to type dots to my hearts content. I have tried reseting to a commit that I knew everything worked and used “get clean -x -d -i” and reloaded the project and I am still getting the same problem in VS. I had just completed the Video “Reporting Errors to Unreal” in the BattleTanks lesson and was beginning the video on using “Clamp()” and am using UE4 version 11.2

I experienced something similar a while back, and solved it by resetting all VS settings:

  1. Open Visual Studio
  2. Select Tools -> Import and Export Settings…
  3. Select Reset all settings and click Next to step trough the wizard. The wizard will let you create a backup before resetting.

Let us know if the above helps, or if you figured out a different way of solving it.

Privacy & Terms