Visual studio Code snippets don't works

hi. i have followed the video and the intellisense, and i still can’t make it work.
when i tried to type “Inst”, it don’t propose me Instanciate()

The C# is installed.
The Unity Code snippets from Kleber is installed.
i have installe .net 7.6 and 6.0. there is no more the Core 3.1
I tried to reinstall Visual code studio.
I’m running of idea on the way to make it works.
If someone can help me.
Thank a lot.

OmniSharp recently decided that they didn’t want to default to supporting Unity anymore (to support the more advanced features in the latest .NET more easily).
Follow the instructions on this link to make OmniSharp work properly.

1 Like

thank you.
i have uncheked omnisharp as they stated in the thread.
i have restarted omnisharp (i think) with this way :
" Ctrl+Shift+P
Then type:
>omnisharp:restart omnisharp
then i don’t have anything telling me it is done.

in the end, it still the same for me and not working. :frowning:
thank for your help.

A few more things to try, and then I would consider using Visual Studio Community instead (it just works!).

  • Make sure your Visual Studio Code plugin in the Unity Package Manager is up to date.
  • Make sure that in Edit/Preferences/External Tools the selected code editor is Visual Studio Code
  • Regenerate Project files.
1 Like

i tried everything. still not working. i will try my luck in Visual Studio Community. thank a lot Brian.
i still not started my course :smiley: damit
Have fun and see you

Hi @Robert_willy,

For some students, VS Code simply does not work well. If nothing helps, install and use Visual Studio (Community Edition).

  1. Download VS and follow this instruction.
  2. Select VS as your External Script Editor in Unity (Edit > Preferences > External Tools).
  3. Install the “Visual Studio Editor” package in the Package Manager.

That should work.

This topic was automatically closed 24 hours after the last reply. New replies are no longer allowed.

Privacy & Terms