Village prefabs which is in World Objects V1.unitypackage could not be shown in scene

I have a problem. when i import World Objects V1.unitypackage asset to Assets/World Objects folder. Then i drag World Objects/Castle/Gallows.prefab to scene, there is show nothing, without Gallows boundingbox. The other prefabs are same problems.
When I check Gallows/Gallows GameObject,

The MeshFilter.mesh is none. Is there a problem?


The initial assets in this course rely on your having Blender installed. You don’t need to user Blender, just have it installed.

The assets are updated later in the course and this requirement is then removed.

Hope this helps. :slight_smile:

See also;

I installed Blender but nothing changed. The prefabs not shown in unity scene.

Did you close and re-open Unity?

yes, and restart computer

Next step then would be to remove the assets and re-import, I don’t recall having to do this, but I think I already had Blender installed before-hand.

I re-import and not work.
Is there directory problem?
I found some .blend files in Blends & FBX folder, there are Castle.blend, Gallows.blend

But village prefabs in World Objects folder

It was quite a long time ago when I looked/helped with this issue, I don’t recall it being this difficult.

Just as a quick test, create a new project and import the assets into that, can you then drag the prefabs into the scene and see them correctly?

I solved this problem.
I delete Blends & FBX folder and World Objects folder. Then re-imported.
it worked.
thanks very much. I appreciated for your help

1 Like

Great, glad to hear you have resolved the issue.

You will find in a later section that the assets get updated (twice from memory), this removes the need to have Blender installed, so you could remove it later if you wanted to - or take one of the Blender courses and you are already prepared! :wink:

ok thanks

1 Like

This topic was automatically closed 24 hours after the last reply. New replies are no longer allowed.

Privacy & Terms