[UNRESOLVED] Tank looks like its hitting invisible bumps moving forward

I made a video showing my problem. And I show what I looked at already to try and fix it.
Click here for video on youtube

It’s a known problem @ben has yet to tackle in the section.

I wouldn’t hold your breath, it may not get fully solved. It is the boundaries between terrain components. There is a solution of using virtual wheels on joints, but may not be worth it. If we me make the ground more bumpy and tweak some other parameters it almost goes away.

I didn’t completely fix it, but I greatly reduced it by changing the track collier to a simplified capsule. I can atleast drice around enough now to do some play tuning.



I’m getting the same issue after lecture 147. “Physics Materials & Friction”.
Is there any solution for this rather than making a capsule collider?

Yes, he takes care of it mostly in a few videos just keep going.

I’m at lecture 187 and I haven’t seen the solution for this bug.
Or am I just missed something?
There was some improving about the tracks, but that didn’t fixed the problem entirely and since then I haven’t seen any related video about the solution.

I’ve fully completed section 4 and as far as I can see, there is no fix yet. The problem is that the tank works GREAT on very flat ground, but if you add in any sort of variation you end up with juttery/slow movement. I’ve decided to just skip the treads entirely and go with a drone tank design that just hovers, fixes the collision issue and it looks freaking awesome.

Looks like you need to turn up the linear/angular damping on the hover tank.

Turn on linear and angular damping. I used a capsule collider instead of a squarish one. And also tweak your track material setting. I’m not getting any bumps.

Linear and Angular damping aren’t physically realistic though, I have linear and angular damping enabled however at higher values it messes with the game physics, try taking your tank off of a ramp and see how slow it falls, thats the linear damping, and if you have a tank flip up its going to rotate very slowly. I like workarounds but those aren’t a real fix.

I actually hadn’t finished the hover mechanic when I recorded that, my new version works much better.

The biggest helper for my project is the capsule colliders on the tank tracks. Reduced it by around 95%. Tweaking the other settings got the rest.

Yeah, that was the first thing I tried. My issue comes from the fact that my terrain isn’t very smooth I think, its a world machine landscape and it has lots of ridges and bumps, so the tank either bounces around or gets damped until it cannot move.

We do have a prototyped solution which creates suspension by ray-casting. The trouble is you then need to make the track move relative to the tank, so we’re really into skeletal meshes and you have to sync the track with the ground. This all gets a little complex for this section.

The fundamental issue is that with this type of mesh, called a polygon soup we confused the collision system at triangle boundaries.

After the final section you should be well equipped to come back and fix this issue, in the meantime it’s a fun challenge.

Ok so I also have this problem and what I have noticed (out of luck) is when I was editing the landscape and my lighting needed to be rebuilt, we end up with this

What I have noticed is that the tank goes over those seams it collides with it and sends the tank flying.

If you rebuild the lighting, then you cannot see the seams, but you still collide at the exact same places.

I have not found a solution to this yet, but will keep trying to solve it!

Thanks for this, changing the collision to a simplified capsule helped a lot. It did not fix all the problem but now i get to slide better, early my tank wouldnt move at all.

I’ve switched by making the original collider almost flat and in the middle of the tread, raised it slightly above the bottom of the tread mesh. Then I’ve added a sphere (scaled down so it’s just smaller than the width of the tread) and have is lined up with the bottom of the mesh with it centered. This seems to be working very well.

I’ve also tried just using spheres but the tank kept on popping wheelies :wink:

Here I’m experimenting with 3 spheres and middle ?plate? colliders.

Privacy & Terms