Unreal Engine not downloading(download button in the library not working)

So,I’ve already asked about it hundreds of times anywhere I can think of,but problem is still not solved.Perhaps someone out there can help me?Otherwise I don’t think I would be able to follow the Unreal course.
The problem is,when I try to donwload any version of Unreal Engine nothing happens.That means,when I click the ‘install’ button,it makes no difference,it just clicks.

I’ve checked the avaible space on my disc,it’s 35 GB,what’s enough for Engine,according to the forum,my firewall is just normal windows security,I tried to reinstall the laucnher,reload the computer but button still doesn’t work.Other versions,as I mentioned,don’t donwload either.

I donwloaded Epic Launcher as default,so there should be no problem in this aspect.Also I often see an ‘S3’ error when I try to log in the launcher,but if I reload compture,everything returns to normal.I don’t know if it can help you to identify the problem,but still better be safe than worry.

So,in the end,I can’t use Unreal Engine at all and follow your lessons,because the crucial element isn’t on my computer.

Do you have any idea why this may happen?How to fix this?

Button is a standart one,but still loaded 2 scrins if there are any questions.

Unfortunately, literally no one is going to know exactly what the problem is. Sounds like you already tried some stuff.

You should uninstall the launcher, fully clean the OS of what’s left of it. In Windows this would mean removing the hidden AppData folder and searching through all of Windows registry for it and removing what’s found (don’t blame me if you can’t or you break Windows), anything else, then rebooting and reinstalling the launcher then trying again.

If after that, it still doesn’t work, then its difficult to say what the issue is and everything Epic does when using the button.

I know with Linux its possible to pull the engine from Github and build so maybe that can also be done on any other OS too? Maybe that’s another way. Or you can keep trying but obviously something happened for you that’s not what Epic expected or wrongly breaks it.

do you mean https://docs.unrealengine.com/en-US/GettingStarted/DownloadingUnrealEngine/index.html ?

Maybe. I’m familiar with using Github to build via Linux and the course videos goes into building from there as well. Not familiar with using a different OS to do this but it does look like the next page does show building it and that it is done from Visual Studio which is cool.

It is the long way around though so only do that if your patience has run out with the download button and/or see which one works first.

Will try,thanks.

Literally, only now either just seen or paid attention to launcher settings.

Notably, there’s enable debug logs and also an item labeled troubleshoot. Both of which, don’t know if you looked into, might give you some idea of why the download button isn’t working. (The debug logs can be found also through an item a bit below the enable checkbox item near troubleshoot item.

Just noting that :slight_smile:

Privacy & Terms