Unreal engine intro project

every time i open the third person template i get this error code immediately.
GPU Crashed or D3D Device Removed.
Use -d3ddebug to enable the D3D debug device.
Check log for GPU state information.

I suggest you update your GPU drivers.

device manager said my Intel(R) UHD Graphics 730 driver was up to date but i did these other two updates and nothing changed when trying to launch the third person perspective intro project.
2022-05 Cumulative Update Preview for .NET Framework 3.5 and 4.8 for Windows 11 for x64 (KB5013889)
2022-05 Cumulative Update for Windows 11 for x64-based Systems (KB5014019)

Is that with a brand new project? You could also try doing a fresh install of the drivers?

yes, i was following along the video and this is the first time id tried to do a project using the unreal engine launcher. id gone through the c++ Fundamentals: Game Programming For Beginners and then i started Unreal 5.0 C++ Developer: Learn C++ and Make Video Games and as soon as i opened the template i got this error message. i just uninstalled and reinstalled the intel driver and it didnt change anything

the computer tower im using is a stock purchase from costco for $700 on sale before the prices spiked as they have in recent months, i think i made the purchase late last year and have not made any modifications to it. is it possible its an internal connection error and id need to open the external case and check the connections?

It could be that some contact in your pc isn’t really in, but that case is very low, because other programs should have complained, too, maybe that is a problem with Unreal, that the Engine couldn’t find it because I had the same issue yesterday, but Unreal Engine 4 worked fine even yesterday for me.
Did you try it today again to launch Unreal, for me Unreal 5 works now?


same response as always, ill see if it will let me load 4.0

Ok, I couldn’t find a real solution in the Unreal forum, for some people it helped to reset the global settings of their graphics card. If you didn’t try it already, I will try finding some more to help.

so, unreal engine 4.27.2 seems to work but its very laggy

I had a similar issue with a new rig running an RTX 3080. Everything else has been perfectly stable, so I suspect it’s something within UE5 itself. It’s difficult to say what it might be with any certainty without any debug info. I know that Nvidia G-Sync caused issues with the editor but that wouldn’t apply in your case.

this is what unreal sends the company
LoginId:676f744c4d1baaf1ea836484280f33b3
EpicAccountId:6a5cf41839ad4f34bda9f4f207133bfa

Fatal error: [File:D:\build++UE5\Sync\Engine\Source\Runtime\D3D12RHI\Private\D3D12Util.cpp] [Line: 859] Adapter->CreateCommittedResource(Desc, GetGPUMask(), HeapProps, InCreateState, InResourceStateMode, DefaultState, InClearValue, &NewResource, InName, false) failed at D:\build++UE5\Sync\Engine\Source\Runtime\D3D12RHI\Private\D3D12PoolAllocator.cpp:371 with error DXGI_ERROR_DEVICE_REMOVED

UnrealEditor_D3D12RHI!D3D12RHI::VerifyD3D12Result() [D:\build++UE5\Sync\Engine\Source\Runtime\D3D12RHI\Private\D3D12Util.cpp:859]
UnrealEditor_D3D12RHI!FD3D12PoolAllocator::AllocateResource() [D:\build++UE5\Sync\Engine\Source\Runtime\D3D12RHI\Private\D3D12PoolAllocator.cpp:371]
UnrealEditor_D3D12RHI!FD3D12PoolAllocator::AllocDefaultResource() [D:\build++UE5\Sync\Engine\Source\Runtime\D3D12RHI\Private\D3D12PoolAllocator.cpp:243]
UnrealEditor_D3D12RHI!FD3D12DefaultBufferAllocator::AllocDefaultResource() [D:\build++UE5\Sync\Engine\Source\Runtime\D3D12RHI\Private\D3D12Allocation.cpp:1468]
UnrealEditor_D3D12RHI!FD3D12CommandContext::RHICopyToStagingBuffer() [D:\build++UE5\Sync\Engine\Source\Runtime\D3D12RHI\Private\D3D12Commands.cpp:659]
UnrealEditor_RHI!FRHICommand<FRHICommandCopyToStagingBuffer,FRHICommandCopyToStagingBufferString>::ExecuteAndDestruct() [D:\build++UE5\Sync\Engine\Source\Runtime\RHI\Public\RHICommandList.h:768]
UnrealEditor_RHI!FRHICommandListExecutor::ExecuteInner_DoExecute() [D:\build++UE5\Sync\Engine\Source\Runtime\RHI\Private\RHICommandList.cpp:498]
UnrealEditor_RHI!FRHICommandListExecutor::ExecuteInner() [D:\build++UE5\Sync\Engine\Source\Runtime\RHI\Private\RHICommandList.cpp:804]
UnrealEditor_RHI!FRHICommandListExecutor::ExecuteList() [D:\build++UE5\Sync\Engine\Source\Runtime\RHI\Private\RHICommandList.cpp:828]
UnrealEditor_RHI!FRHICommand<FRHICommandWaitForAndSubmitRTSubList,FRHICommandWaitForAndSubmitRTSubListString1627>::ExecuteAndDestruct() [D:\build++UE5\Sync\Engine\Source\Runtime\RHI\Public\RHICommandList.h:768]
UnrealEditor_RHI!FRHICommandListExecutor::ExecuteInner_DoExecute() [D:\build++UE5\Sync\Engine\Source\Runtime\RHI\Private\RHICommandList.cpp:498]
UnrealEditor_RHI!FExecuteRHIThreadTask::DoTask() [D:\build++UE5\Sync\Engine\Source\Runtime\RHI\Private\RHICommandList.cpp:560]
UnrealEditor_RHI!TGraphTask::ExecuteTask() [D:\build++UE5\Sync\Engine\Source\Runtime\Core\Public\Async\TaskGraphInterfaces.h:975]
UnrealEditor_Core!FNamedTaskThread::ProcessTasksNamedThread() [D:\build++UE5\Sync\Engine\Source\Runtime\Core\Private\Async\TaskGraph.cpp:753]
UnrealEditor_Core!FNamedTaskThread::ProcessTasksUntilQuit() [D:\build++UE5\Sync\Engine\Source\Runtime\Core\Private\Async\TaskGraph.cpp:642]
UnrealEditor_Core!FTaskGraphCompatibilityImplementation::ProcessThreadUntilRequestReturn() [D:\build++UE5\Sync\Engine\Source\Runtime\Core\Private\Async\TaskGraph.cpp:2115]
UnrealEditor_RenderCore!FRHIThread::Run() [D:\build++UE5\Sync\Engine\Source\Runtime\RenderCore\Private\RenderingThread.cpp:325]
UnrealEditor_Core!FRunnableThreadWin::Run() [D:\build++UE5\Sync\Engine\Source\Runtime\Core\Private\Windows\WindowsRunnableThread.cpp:146]

I don’t suppose you have MSI Afterburner, RivaTuner, or some other GPU/Hardware monitoring software running, do you? I got the same error as you and as soon as I turned off my overlays it worked without issue.

its just a stock pc tower from costco. unless it was installed and setup to run that software in the factory or by steam i doubt that its running.

I found others with a similar issue on the UE forums. Lowering the editor framerate seemed to help a lot of people with the same issue so I did the same and so far the editor has been stable.

You can set Fixed Frame Rate under Project Settings > Engine > General Settings > Framerate. I set mine to 90 and the editor hasn’t crashed with the same issue yet.

no idea what happened, i just know that UE 5.0.2 came out and now its letting me into projects. so the first thing i did was hit the engine scalability settings and moved it from epic to low and now its not crashing. ill start working my way through the instructional videos tomorrow and let you know if theres a change.