Unreal Engine 5 freezes while creating actor/pawn blueprint class

While learning the Unreal Course with C++ and Blueprints, I’m stuck at a point where I’m required create a sub-class for an actor. When I try to create the Blueprint the Unreal Engine software gets frozen. I need your help guys.

I tried to change the performance settings and clearing the temp files and everything. Nothing works. Tried to change versions, still same issue. I will attach the logs below.
Tried to create bp from Details pane of the actor and also tried to create from empty bp. Same issue.


[2024.01.22-21.20.43:307][406]LogActorComponent: UnregisterComponent: (/Game/Sphere2_Blueprint.Default__Sphere2_Blueprint_C:StaticMeshComponent0) Not registered. Aborting.
[2024.01.22-21.20.43:314][406]LogUObjectHash: Compacting FUObjectHashTables data took 0.57ms
[2024.01.22-21.20.43:334][406]LogAssetEditorSubsystem: Opening Asset editor for Blueprint /Game/Sphere2_Blueprint.Sphere2_Blueprint
[2024.01.22-21.20.43:335][406]LogChaos: FPhysicsSolverBase::AsyncDt:-1.000000
[2024.01.22-21.20.45:337][406]LogStall: Stall detector ‘UAssetEditorSubsystem::OpenEditorForAsset’ exceeded budget of 2.000000s, reporting…
[2024.01.22-21.20.46:140][406]LogStall: Stall detector ‘UAssetEditorSubsystem::OpenEditorForAsset’ report submitted, and took 0.049926s

Just an extension to the issue.
I tried creating an empty Blueprint class for an actor in UE 4.27 and it works. Not working in any of the UE 5 versions.

There’s not much documentation on this particular issue (it seems to be super rare) but a few things that come to mind.

If you have another hard drive that you can have your project stored in, see if the issue still occurs there. Otherwise, double-check that you aren’t experiencing hard drive failure (you can do this through tools like seagate’s seatools, hard drive manufacturer doesn’t matter)

1 Like

Hi Tuomo,

Thanks for your advise. As you suggested I have tried to start a new project in another Hard Drive. But its still having the same issue.
What I noticed this time is that whenever I tried to create a BP for an object already in the scene it is working. So the issue is only whenever I try to open an empty BP or create a BP for a newly created Actor.
It doesn’t actually make sense.
Tried the Seatools and it says “Short Self Test Passed”.

This topic was automatically closed 20 days after the last reply. New replies are no longer allowed.

Privacy & Terms