Unreal Compile output log takes me to ToonTanks.Code-workspace

Whenever I run the compile in unreal for the toon tanks game and I get an error when I click on the link in the editor to find the error it brings me to this page. With no code? I am not sure what is wrong but for the previous project it would actually bring me to the line any idea what has happened and how I can change it back to so that the unreal debugger brings me to the actual line of code that is the issue?

Thanks in advance!

try to go to your project folder and right click your project. And then click “Generate project files”. Maybe that would fix this.

Nope didn’t work. Just to make sure I did it correctly. I in explorer the browsed to the Uproject ToonTanks right clicked and Generated Visuals Studio Project files.

Just to make sure it wasn’t a hot load issue I close both the engine and and visual studio and reopend them and am still receiving the same problem.

Both the files open but I don’t know why it keeps opening the ToonTanks.code-workspace.

yes you did it correctly. It does this with every error?

  1. Could you double check you have your preferred editor selected in Edit > Preferences > Source Code?
  2. Could you show what exactly you’re clicking on?

I made a quick video to show the issue

Hopefully it helps to show the issue.

Also I checked my source code it is set to Visual Studio Code.

Thanks for helping me.

Well that’s precisely what I feared. It’s exactly as you said.

Could you try deleting the code-workspace file and .vscode directory and then generating them again? Either by right clicking the .uproject file or through Unreal’s File menu

I have tried deleting those files and generating them both in the editor and via the unreal file menu. Still the same result.

Issue was in the header I have an FVector miss named…

1 Like

This topic was automatically closed 24 hours after the last reply. New replies are no longer allowed.

Privacy & Terms