Unity Project Not Opening

I tried opening my unity project but it is not opening. I click on my project but it remains unresponsive. I tried adding it again but it still does not open.

What to do?

Hi Mehtab,

Have you tried to restart Unity Hub? And do any messages pop up when you try to launch the Uncle Jones project?

Is F:\ an internal harddrive?

Yes, My project did not open.

No. nothing. I just kept clicking and nothing happened.


Try to start Unity Hub with administrator rights. If that doesn’t work, reinstall Unity Hub. And if that doesn’t work either, try to open your project without Unity Hub.

And if it still does not work, try to open the project, wait a few seconds, then press ctrl + shift + esc to open the Task Manager. Check if Unity is in the “Processes” list. If it’s not, Unity was very likely not launched. Try to reinstall Unity.

It did not work.

Did not work

It worked.

But I need to install assets from asset store and it works only with unity hub…

Have you tried to open the Asset Store tab in Unity?

Yes, my unity version is 2020.1.1f1 and it says that asset tab has been moved. Now it has a package manager which says “sign in” to see your assets.

You have to log into your Unity account.

But it instructs me to install unity hub and when I finish and try to start unity again, it does not start again.

Maybe that was changed in the Unity 2020 versions. I have not installed it yet.

Do you have a firewall or an antivirus program that could be blocking Unity or Unity Hub?

If not, and if you cannot run Unity Hub or open your project anymore, and if reinstalling did not help, I would suggest to report a bug to Unity.

Maybe you could look for a thread in the official Unity forum and create one if you could not find any thread which covers the same issue as yours.


This topic was automatically closed after 7 days. New replies are no longer allowed.

Privacy & Terms